EoIP melalui Tunnel PPTP

skema eoip-pptp

Kebutuhan akan ip publik terus meningkat seiring dikembangkanya server – server yang diakses secara publik melalui internet seperti web server, mail server, ftp server dll. hal ini bukanlah masalah bagi perusahaan berskala menengah – besar karena sanggup menyewa koneksi dedicated dengan satu blok ip publik.yang menjadi permasalahan adalah ketika suatu instansi tersebut berskala kecil dan menyewa koneksi kelas user seperti sp**dy dsb.

disini saya membuat contoh kasus dimana server A berada pada sekolah SMP N 01 dan server B berada di NOC Pemda setempat. keduanya sepakat untuk memberikan SMP N 01 tersebut satu ip publik yang akan dilekatkan pada server A sebagai server Penerimaan Siswa Baru Online. jaringan di NOC Pemda memiliki satu blok ip dengan prefik /29 yang terkoneksi ke internet dengan routing bgp, sedangkan jaringan SMPN 01 koneksi internet menggunakan rt/rw net yang menggunakan ip lokal (tidak mendapat alokasi ip publik). kedua jaringan menggunakan router mikrotik.

langkah pertama yang kita buat adalah membuat vpn (virtual private network) terlebih dahulu melalui PPTP (Point to Point Tunneling Protocol)  untuk membuat jaringan point to point. Jaringan point to point ini akan kita gunakan untuk melewatkan EoIP (Ethernet over IP) untuk mentransfer ip publik dari R2 ke R1. disini yang saya buat menjadi pptp server adalah R2 karena memiliki ip publik sedangkan R1 saya jadikan pptp client. konfigurasinya sebagai berikut :

R1:

 /interface pptp-client add name=pptp-noc user=smpn1  password=1234 connect-to=202.xx.xx.146 disabled=no

R2:

/interface pptp-server server set enabled=yes
/ppp secret add name=smpn1 service=pptp password=1234 local-address=10.1.101.1 remote-address=10.1.101.2

pada router R2 interface pptp-server harus di enable kan terlebih dahulu kemudian membuat secret dengan nama dan password serta ip point to point yang sudah ditentukan. secara otomatis R1 akan dial ke R2 dan akan membentuk jalur vpn. untuk melihat apakah vpn sudah terbentuk atau belum, dapat dilihat menggunakan perintah /interface print maka akan muncul daftar interface :

 0  R  ether1-INET                           ether             1500  1598       9498
1  R  ether2-SERVER                     ether             1500  1598       9498
2  R  ether3-LAN                            ether             1500  1598       9498
3  R  pptp-noc                                 pptp-out       1460

pada interface pptp-noc menunjukan status “R” yang artinya terhubung. jika interface pptp-noc belum muncul maka periksa kembali user, password dan ip tujuan. langkah selanjutnya adalah membuat EoIP antara R1 dan R2 melalui vpn yang telah kita buat. caranya adalah sebagai berikut :

R1:

/interface eoip add name=eoip-noc tunnel-id=31  remote-address=10.1.101.1

R2:

/interface eoip add name=eoip-smpn1 tunnel-id=31  remote-address=10.1.101.2

Yang perlu diperhatikan adalah tunnel-id di kedua router haruslah sama. untuk remote address masukkan ip point to point dari vpn yang telah dibuat tadi. setelah EoIP terbentuk maka langkah terakhir adalah membuat bridge untuk menghubungkan EoIP tersebut dengan interface yang akan dilalui ip publik. caranya sebagai berikut :

R1:

/interface bridge add name=eoip-bridge
/interface bridge port add bridge=eoip-bridge interface=ether2
/interface bridge port add bridge=eoip-bridge interface=eoip-noc

R2:

/interface bridge add name=eoip-bridge
/interface bridge port add bridge=eoip-bridge interface=ether1
/interface bridge port add bridge=eoip-bridge interface=eoip-smpn1

konfigurasi EoIP melalui PPTP sudah selesai sampai disini. untuk selanjutnya server A tinggal dikoneksikan ke ether2 dari router R1 dengan ip publik yang di setting static (konfigurasi menyesuaikan pada network NOC Pemda). dengan EoIP ini, server A akan berada satu jaringan dengan server B. CMIIW

Source : https://getihmacan.wordpress.com/2014/05/14/eoip-melalui-tunnel-pptp/

Posted on: August 26, 2020, by :